• 🔖 It looks like you are browsing the site as a guest. By registering on the site you can participate on the Internet's largest Polaris Ranger XD 1500 forum. To register, simply Click Here!

error code 517625 came up

Jeff G

Member
Dec 6, 2023
28
33
Does any one know what this error code means 517625 My triangle light on the dash is blinking. Thanks
 
Last edited:
Go to start the ranger no power to the dash I checked the battery voltage its good 12.65 volts . also checked all connections at battery Anyone have any suggestions. I thought I would get more than 37 miles before it goes back to the shop.
 
Doesn’t look like collectively we are any help. Machine too new. I am guessing you will need to have your dealer address issue. Let us know what it was. That sucks. Hope it’s simple and a one off.
 
I got a 517826 tonight. Engine cut out for a little bit then came right back and check engine light came on. It was good the rest of the night. Not sure what it was?
 
Dealer got back to me this morning, Polaris told them that they have to replace the complete engine harness NOT WHAT I WANTED TO HERE. something is pinched causing intermittent problems Also causing these different codes. Harness could be pinched during assembly.
 
Damn! QC is lacking in some cases. The painted panel being the most egregious that NH1500 had to deal with, but this should have been caught too.
 
Last edited:
I seen a few posts on other sites also about random and intermittent codes and going away. I just hope this is not a trend. The machine is great, Polaris did a great job with all the features engine, tranny. smoothness etc. I am tired of Polaris using the customer for quality control. 37 miles is not enough reliability to me. So frustrating.
 
Just a update supposed to pick up my machine tomorrow after two weeks in the shop. Dealer installed new chassis harness and VCM MODULE hopefully I will get my second ride in. Will keep you guys posted.
 
Got my machine back today, got a few miles on it and installed my sun visors. hopefully I be ok
Glad it’s back and you are in the saddle again. What a mess you have had. Hopefully it’s a complete anomaly and you have nothing but reliability from this point!
 
Got my machine back today, got a few miles on it and installed my sun visors. hopefully I be ok
I know it's off topic but how did the sun visor install go? I started mine last weekend and was concerned that the brackets were not going to end up in the right place. Instructions say to cut head liner "where it's marked" mine was not marked. The bracket was not going to end up in the pocket but more out to the door side than looked correct. I was concerned that there might not be room to bolt the visor to the bracket when it was done. Can you send a picture of your installed?
 
The bracket favors the door side. the headliner is not marked. It's still in the pocket. There is room for the bolts. the bracket covers the push pin hole in the headliner. You feed the head liner over the bracket, up and over and it fits nice and snug.
 

Attachments

  • IMG_1674 visor.jpg
    IMG_1674 visor.jpg
    52.6 KB · Views: 2
  • IMG_1673.jpg
    IMG_1673.jpg
    37.9 KB · Views: 4
  • IMG_1672.jpg
    IMG_1672.jpg
    60.8 KB · Views: 4
  • IMG_1668.jpg
    IMG_1668.jpg
    41.1 KB · Views: 6
  • IMG_1670 (1).jpg
    IMG_1670 (1).jpg
    42.1 KB · Views: 3
  • IMG_1669.jpg
    IMG_1669.jpg
    32 KB · Views: 5
The bracket favors the door side. the headliner is not marked. It's still in the pocket. There is room for the bolts. the bracket covers the push pin hole in the headliner. You feed the head liner over the bracket, up and over and it fits nice and snug.
Yours looks like mine was going to end up. Maybe I'll get around to it Sunday, it's not that hard it just didn't seem correct to me. Thanks for the photos!!
 
Can any body help me with a code 1557 is or where I can find it . my check engine light came on. Thanks
 
I downloaded the ride command app on my phone . There is a error code look up. I punched in the code c1557 and it said LEFT HAND CONTROL IN BOOTLOADER MODE. WHAT THE HELL IS THAT. IT SAID TO CONTACT DEALER. Three rides 61 miles around my house on pavement never seen grass or dirt yet. Frustrating.
 
I downloaded the ride command app on my phone . There is an error code look up. I punched in the code c1557 and it said LEFT HAND CONTROL IN BOOTLOADER MODE. WHAT THE HELL IS THAT. IT SAID TO CONTACT DEALER. Three rides 61 miles around my house on pavement never seen grass or dirt yet. Frustrating.
Have no idea what that is. It’s Like another punch in the gut for you. Fingers crossed this is something really simple. Hope they can get it right for you so the remorse can stop. Really sucks! you have had far and away the worst QC problems of any of us. So sorry!
 
Got it back from the dealer They said one of the fan plugs wasn't plugged in all the way. snapped it in all the way engine light went out.
 
Back
Top